Summary:

 

If you are planning to use or upgrade your Postgres back end database to version 12 you might find errors in the Aqua console log in any Aqua version prior to 5.0.20306 (Update 16) 



Environment: 


Aqua CSP 5.0 



Solution: 


Upgrade at least to 5.0.20306(Update 16) or higher available version, https://docs.aquasec.com/docs/50-update-16 If this is not an option you could use Postgres 11 and that will allow you the Aqua CSP installation. 



Related Information: 


https://docs.aquasec.com/docs/50-update-16 

https://docs.aquasec.com/docs/performance-related-best-practices 

https://docs.aquasec.com/docs/aqua-database-recommendations